× Post your Help request here

Build Failed at :compileJava (with error log)

  • Posts: 21
  • Thank you received: 0

gigiandearl created the topic: Build Failed at :compileJava (with error log)

Title says it all, yesterday i was running the build with no issues and now all of the sudden it keeps getting stuck at :compileJava Please help!

02.10.2017-23:17:27.1347 -> - Form_PackageExplorer_016- Minor - Line: 0
Generic
System.IO.FileNotFoundException: Could not find file 'C:\Users\W510\Documents\Toolbox 2.0\Forge\build.gradle.bak'.
File name: 'C:\Users\W510\Documents\Toolbox 2.0\Forge\build.gradle.bak'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost)
at System.IO.File.InternalReadAllText(String path, Encoding encoding, Boolean checkHost)
at System.IO.File.ReadAllText(String path, Encoding encoding)
at Toolbox_2._0.Form_PackageExplorer.AddToBuild()

#79854
The topic has been locked.
  • Posts: 21
  • Thank you received: 0

gigiandearl replied the topic: Build Failed at :compileJava (with error log)

Nvm, I figured it out myself, I solved it by going into C:\Users\W510\Documents\Toolbox 2.0\Forge\.gradle finding the gradle file and looking at the error which was:
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava UP-TO-DATE
:compileJavawarning: [options] bootstrap class path not set in conjunction with -source 1.6
C:\Users\W510\Documents\Toolbox 2.0\Forge\build\sources\java\com\flansmod\client\model\mw\ModelMachineGun.java:10: error: <identifier> expected
package com.flansmod.client.model.-; //Path where the model is located
^

So I just changed the "-" to mw

#79855
The topic has been locked.
 
Latest Forum Posts
 
Latest Blog Posts
 
User Online
 
User Menu